WL Jeep Forum

Welcome to WLJeepforum.com! Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Has anyone had the latest software loaded by your dealer? Did it help?

mja997

Well-known member
I had it installed and the off rod peg came back. Can’t really tell about anything else.
 

Fdot

Member
Good morning!

To find the software information for your Uconnect system, you can follow these steps:

Go to “Vehicle Settings” then select “ System
Information” and look for “Radio version”

If you have any questions, feel free to let us know!

Courtney
Jeep Cares
My car does not say radio version
It says
Model
Android version
Android security patch level
kernel version
Build number
 

mja997

Well-known member
So confused, I had the update and Off road page came back for over a week. Yesterday the off road page was missing again only to come
back today. WTF is really going on.
 

PRspawn

Well-known member
So confused, I had the update and Off road page came back for over a week. Yesterday the off road page was missing again only to come
back today. WTF is really going on.
Try switching to another profile and then back. No idea why it works, but it worked for me.
 

yurguis

Member
I have the exact same version.
By reading some of the comments, seems to me that there are two complete different versions, one for 8.4 systems and another for 10.1 systems.
Uconnect site keeps displaying that for my VIN there is no recall nor update, I have a GC L Altitude.
 

JeepCares

Well-known member
I have the exact same version.
By reading some of the comments, seems to me that there are two complete different versions, one for 8.4 systems and another for 10.1 systems.
Uconnect site keeps displaying that for my VIN there is no recall nor update, I have a GC L Altitude.
Hi there,

Please follow up with our teams privately, providing your VIN and details about your concerns, so we can look into this for you.

Thanks,

Courtney
Jeep Cares
 

mja1228

New member
can't you get the update without going to the dealership? if you allow software updates over wifi, does it update properly?
 

aaltaf22

Member
The update didn’t immediately bring back the off road pages for me. After getting the update at the dealer, I got home and did a factory reset and it came back.
Wireless Carplay seems to connect better than it did before but still pretty inconsistent.
in car Wi-Fi doesn’t work and the weather app doesn’t update. Resetting to factory defaults didn’t seem to fix that.
At the dealer now and they said they’ll try a software update. Let’s hope it fixes it!
 
Top