WL Jeep Forum

Welcome to WLJeepforum.com! Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Display Flickering

GoBigRed

New member
I’ve got a 2021 Grand Cherokee L Overland addition. Anyone encounter any problems with their display flickering on an off? Thought that the most recent update would’ve taken care of the issue but still happening.
 

Sbradle4

Well-known member
I’ve got a 2021 Grand Cherokee L Overland addition. Anyone encounter any problems with their display flickering on an off? Thought that the most recent update would’ve taken care of the issue but still happening.
This is a pretty awesome feature that the Stellantis engineers created specifically to piss off the people that spent their hard earned money on these pieces of garbage.
 

eleceng1979

Well-known member
Yes, mines does it too, automatically. I’ve read the manual and some positive post here but it didn’t help. Still holding out for the software update that won’t fix it.
 

Sarge

Well-known member
Mine got so bad they finally put new guts in it (not the screen, but the computer). Eventually I had no audio capabilities and couldn't use Uconnect for anything (it was constantly resetting). But it all started with random infrequent flickering. Since it was replaced, my wife has seen it flicker a few times, but I haven't caught it on video yet. I don't know what to think.
 

Riviera

Well-known member
Mine locked up yesterday while inputting an address in the navigation, then seemed to fully shut down and reboot. The whole process took only 2 minutes but it felt like an hour as I was in a hurry. We had a similar issue on our 2020 Wrangler that ultimately required replacing the radio after several attempts to update software. Hopefully my experience yesterday was a fluke and won't happen again.
 

wowsa

Well-known member
I had no issues until a few months ago. Now once or twice a day I will get a random flicker where the screen turns off then 1/2 second later turns back on.
 

Rykomm

Member
I was getting the flickering/reboot issue at least once a day. After the update came in OTA on march 15, it has not happened again but keeping my fingers crossed.
 

Riviera

Well-known member
My screen does it randomly, sometimes 3 times in a half hour, sometimes not at all. The audio seems unaffected.
 

Sarge

Well-known member
After the most recent update my display seems good. Prior to that, it had flickered a few times (even after new ECU/CPU for Uconnect). Prior to the Uconnect replacement, it was mostly unusable, but that too started with flickering. It seems like a supplier problem with the electronics hardware, since some have no issues at all, ever, while some of us get a complete mess.

It's possible that more robust coding in recent updates can overcome the issue, but it may also be hardware-based. They're trying to get to the bottom of it.
 

weezmatic

Member
Overland 5.7 here. They replaced my original screen after it completely died a couple months after purchase. The replacement screen flickers.
 

Sarge

Well-known member
Overland 5.7 here. They replaced my original screen after it completely died a couple months after purchase. The replacement screen flickers.
Yep. Same here. At least it mostly works now. Wireless CarPlay is still random in terms of how long it takes to connect (if ever), but the occasional flickering is at least livable, if not 'right'.

Automakers seem to have spent too little on their computer systems in general, and are all moving into the digital age as though all their systems were designed and approved by 'boomers'. The hardware in the newest systems is ancient and under-specced, and the software is betaware compared to most systems in other industries. It feels like the best you can hope for is 'mostly functional most of the time'.
 
Top